Restructuring cs:names and cs:name

Is there a reason why the delimiter-precedes-last, and and
name-as-sort-order attributes are set on cs:name instead of on cs:names?
These seem properties of the name list, instead of of the individual names,
so I find their current placement a bit curious. Also, I think it would make
more sense to drop delimiter from cs:name, and use delimiter on cs:names
instead to delimite the names in the name list.

Also, I guess we should extend the values of the cs:name-part name attribute
from { “family” | “given” } to { “family” | “given” | “suffix” |
“non-dropping-particle” | “dropping-particle” }.

Rintze

Is there a reason why the delimiter-precedes-last, and and
name-as-sort-order attributes are set on cs:name instead of on cs:names?
These seem properties of the name list, instead of of the individual names,
so I find their current placement a bit curious. Also, I think it would make
more sense to drop delimiter from cs:name, and use delimiter on cs:names
instead to delimite the names in the name list.

Seems fine.

Also, I guess we should extend the values of the cs:name-part name attribute
from { “family” | “given” } to { “family” | “given” | “suffix” |
“non-dropping-particle” | “dropping-particle” }.

What formatting do you expect to attach to these?

Also, I remain really uncomfortable with the “dropping” particle
language. I really think we need to find more standard/clear language
for this.

Bruce

WikiPedia has a page dedicated to name representation in their system,
and it includes some on this issue.

http://en.wikipedia.org/wiki/Wikipedia:Persondata#Name.2C_alternative_names_and_titles

But no particular language.

More:

http://en.wikipedia.org/wiki/Wikipedia:Categorization_of_people#Sort_by_surname

This …

http://www.library.yale.edu/cataloging/music/entryele.htm

… uses different language (prefix, etc.).

Don’t know, maybe we could have “particle” and something like
"family-prefix"? Not sure if that’s captures it or not.

Bruce

Is there a reason why the delimiter-precedes-last, and and
name-as-sort-order attributes are set on cs:name instead of on cs:names?
These seem properties of the name list, instead of of the individual names,
so I find their current placement a bit curious. Also, I think it would make
more sense to drop delimiter from cs:name, and use delimiter on cs:names
instead to delimite the names in the name list.

Seems fine.

No, Mr Bill, Nooooooooooooooooo!

This has come up in the past, and there’s a reason why things are
arranged as they are.

In fact, the name element does not pertain to a single name, but to a
set of names contained within a single variable. This would be
clear if the names element were instead called “namesets” and the name
element “nameset”. But it’s fun to revisit this topic periodically,
so it’s probably worth keeping the current naming scheme in place. :slight_smile:

The delimiter set on the names element is the delimiter placed between
namesets when two variables are given (i.e. variable=“author editor”).
The delimiter set on the name element is the one that goes between
names within a variable’s nameset. The and= and other attributes on
the name element are in the right place, because “name” in this case
refers to a “name variable” or nameset, not to an individual person’s
or institution’s name.

Frank

Also, I guess we should extend the values of the cs:name-part name
attribute
from { “family” | “given” } to { “family” | “given” | “suffix” |
“non-dropping-particle” | “dropping-particle” }.

What formatting do you expect to attach to these?

Personally none. But it seems a logical extension without any downsides
(i.e. I can’t come up with a good reason to limit the values to “given” and
"family"). Alternatively, any formatting set to “given” could affect both
the given name and dropped-particles, while the formatting set to "family"
could affect not only “family”, but “suffix” and “non-dropping-particles” as
well.

Also, I remain really uncomfortable with the “dropping” particle

language. I really think we need to find more standard/clear language
for this.

Quite a few sources use the verb “drop” to indicate that some particles are
dropped. But I agree that non-dropped-particles doesn’t really shine.

Rintze

Ah right!

Which underlines the point that the names/name distinction ain’t
clear. But OTOH, maybe it is “fun.” Plus, I think it would be hard to
make more clear without also making it more complex (with multiple
namesets).

Bruce

How about renaming cs:names and cs:name to respectively cs:name-lists and
cs:name-list?

Rintze

Well, for sake of argument/comparison, maybe something like:

... ....

So more clear, perhaps, but without additional changes (like default
name config), more verbose, and leads to redundant templates (bad).

Bruce