et al - text / and - symbol

Hi all,
I’d have some questions regarding the creation of a citation style.

1.) where can I set the values of the text which appears, if there are f.e.
5 authors at one book? I want the “et al” to appear but “u.a.” (german
abbreviation) gets into scene.

2.) It’s the same with the AND=“symbol” item - the & - Sign appears (if
there are more authors), but I want a slash instead - I can’t find values
like that neither in the database nor in the GUI itself.

Greetings & Thanks---------------------------------------------------------
Einfach auf diese Mail antworten, wenn jemand keine Emails dieser Art
empfangen will etc.

Sorry I missed this Georg,

Georg Fankhauser wrote:

I’d have some questions regarding the creation of a citation style.

1.) where can I set the values of the text which appears, if there are
f.e. 5 authors at one book? I want the “et al” to appear but “u.a.”
(german abbreviation) gets into scene.

This is set in the locales files, which lists:

 <term name="et-al">u. a.</term>

… for German. Is that incorrect, or are you simply wanting English output?

2.) It’s the same with the AND=“symbol” item - the & - Sign appears (if
there are more authors), but I want a slash instead - I can’t find
values like that neither in the database nor in the GUI itself.

This might be another issue with the locales file. If you’re saying the
"/" is the standard way to do this in German (that you don’t use “&”),
then we need to add this to the German locales.

 <term name="and" form="symbol">/</term>

Is that right?

Bruce

I don’t believe that this is the way it works at the moment, but it
would be relatively easy to modify.

Simon

Hi Bruce, I could not find the statement…
u. a.
can I set them by myself or are they “hard coded” in the firefox - plugin or
elsewhere?

Regarding the “et-al”: the “u.a.” for German is not wrong! still there are
also citation Styles like the one of the Management Center Innsbruck (in
Austria), which uses the term “et al” and not the german correspondent “u.a.”.
It’s basically the same with the & -
the & is not generally wrong - but doesn’t match with our citation style.

I just want you to consider the following:
I’d suggest, that you keep up the thing with the language specific presets
(like the et-al etc.) BUT
from a developers point of view it would be extremely helpful if you could
set EVERYTHING in the xml-File for the database -
I could imagine that there are some presets in the general database and
plugin, but if overwritten in the xml-File, then the specific entry is
taken!

I’ve now managed to adapt the style for our university (and will use it for
my diploma thesis).
But I had to apply some “additional local” hacks: f.e. to get the "et al"
instead of the german “u.a.” add line
extensions.zotero.export.bibliographyLocale in “about.config” in Firefox
I would definitely suggest zotero to my colleagues or the university but I
am not interested in teaching them how to add those local hacks.
It would be much easier to just supply the fully defined specific
XML-Statement to the zotero general database without having to worry about
anything.

Greetings Georg-------------------------------------------
Bruce wrote:

Sorry I missed this Georg,

Georg Fankhauser wrote:

I’d have some questions regarding the creation of a citation style.

1.) where can I set the values of the text which appears, if there are
f.e. 5 authors at one book? I want the “et al” to appear but “u.a.”
(german abbreviation) gets into scene.

This is set in the locales files, which lists:

<term name="et-al">u. a.</term>

… for German. Is that incorrect, or are you simply wanting English output?

2.) It’s the same with the AND=“symbol” item - the & - Sign appears (if
there are more authors), but I want a slash instead - I can’t find
values like that neither in the database nor in the GUI itself.

This might be another issue with the locales file. If you’re saying the
"/" is the standard way to do this in German (that you don’t use “&”),
then we need to add this to the German locales.

<term name="and" form="symbol">/</term>

Is that right?

Bruce

2008/2/12, Simon Kornblith <@Simon_Kornblith>:

Georg Fankhauser wrote:

I just want you to consider the following:
I’d suggest, that you keep up the thing with the language specific
presets (like the et-al etc.) BUT
from a developers point of view it would be extremely helpful if you
could set EVERYTHING in the xml-File for the database -
I could imagine that there are some presets in the general database and
plugin, but if overwritten in the xml-File, then the specific entry is
taken!

I’m not sure what you mean about the “xml-file for the database”. Do you
mean a generic preset for the application (say Zotero)?

If yes, I’m not sure that’d be a good solution, since you just said that
the conventions vary. Your institution may say use “et al” but some
other German style may use the standard default. In that case, it would
fail.

FWIW, you can include terms in a style. We’ve not really talked about it
AFAIK, but I wonder if that wouldn’t be a way to override the generic
language settings. My thinking is that if you included, say, this in
your CSL …

/

… it would override the definition in the locales file(s).

As I said, though, I’m not sure if we’ve ever talked about this
explicitly. I presume that would work for you?

Simon, what do you think?

Bruce

I’m not sure what you mean about the “xml-file for the database”.
Do you mean a generic preset for the application (say Zotero)?

I’m sorry for being imprecise :wink:
what I really meant with “xml-file for the database” is actually the
XML-Part of my own citation style.
f.e. the 4th (last) parameter in the statement:
REPLACE INTO csl VALUES(‘http://www.zotero.org/’, ‘2008-02-02 13:00:00’,
‘MCI by gefa’,’<?xml version="1.0" encoding="UTF-8"?> … (citation
style) settings following

If this really works out if I include the statement you provided in my own
citation style as you provided then this would be fine for me.


/

To concretize my statement from before (although you already got the most
correctly):
I just wanted to say, that I don’t find it useful that there are some items
like the “et al” and “and-symbol” which are kind of hardcoded in the
software depending on the local settings.
In my eyes a citation style should be fully defined in the database and
there shouldn’t be any adjustments depending on language / local settings.

But that’s only my point of view ;)2008/2/13, Bruce D’Arcus <@Bruce_D_Arcus1>:

Georg Fankhauser wrote:

If this really works out if I include the statement you provided in my
own citation style as you provided then this would be fine for me.


/

I’d encourage you to experiment with this, then, and let us (or more
specifically the Zotero devs) know how it goes, or if there can be some
improvements (e.g. the override doesn’t work, it needs to probably be
fixed).

To concretize my statement from before (although you already got the
most correctly):
I just wanted to say, that I don’t find it useful that there are some
items like the “et al” and “and-symbol” which are kind of hardcoded in
the software depending on the local settings.
In my eyes a citation style should be fully defined in the database and
there shouldn’t be any adjustments depending on language / local settings.

But that’s only my point of view :wink:

The original design followed your preference, but a lot of people
complained about the implications of this, since it would mean every
language would need it’s own style.

So we went with an approach which is intended to provide the best of
both worlds: language-agnostic defaults, but the ability to override
within the style.

But the internationalization stuff hasn’t been heavily tested, so your
experiences are valuable. Even more valuable would be to have some
testing by people from Asia, who work with languages and scripts that
have very different logics than Europe and N. America.

Bruce

I’ve tested it out - it works!
first I deleted the entry in the firefox about:config and set
extensions.zotero.export.bibliographyLocale to ""
then I tried to cite in ms office and the german “u.a.” came up for the
et-al.

Then I’ve updated my citation style by adding …


et al.


… right after the tag.

Then I cited again and the “et al.” appeared.

@how to handle locale /multiple language things:
I think there are pro’s and con’s for both alternatives - basically if you
can override anything, then it’s exactly what I was looking for.

Keep up with the great work
Thanks2008/2/13, Bruce D’Arcus <@Bruce_D_Arcus1>: